# Table of Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Table of Contents</td>
<td>i</td>
</tr>
<tr>
<td>1.0 Introduction</td>
<td>1</td>
</tr>
<tr>
<td>2.0 Prerequisites</td>
<td>3</td>
</tr>
<tr>
<td>2.1 Graphical Requirements</td>
<td>3</td>
</tr>
<tr>
<td>2.2 Advanced Mode Installation</td>
<td>3</td>
</tr>
<tr>
<td>2.3 License Requirements</td>
<td>4</td>
</tr>
<tr>
<td>3.0 User Account Creation</td>
<td>5</td>
</tr>
<tr>
<td>4.0 Floorplan Volume Creation</td>
<td>7</td>
</tr>
<tr>
<td>5.0 LFM NetView Project Publishing</td>
<td>9</td>
</tr>
<tr>
<td>6.0 VHD Creation (Cloud deployment only)</td>
<td>13</td>
</tr>
<tr>
<td>Disclaimer</td>
<td>19</td>
</tr>
<tr>
<td>Trademarks</td>
<td>19</td>
</tr>
<tr>
<td>Copyright</td>
<td>19</td>
</tr>
</tbody>
</table>
1.0 Introduction

LFM NetView project creation is a one off operation which is performed in LFM Server: Server Mode. LFM NetView project creation is a completely lossless process in which none of the data from the original scans is lost.

There are three different ways of hosting an LFM NetView project. These are:

- Hosted on LFM Software’s cloud account (hosting fee applies)
- Hosted on your own cloud account
- Hosted on an in house server

This document will cover the hosting process, starting from the point where the LFM Server dataset (.lfd) is available, up to and including the point of Virtual Hard Drive (VHD) creation. After this point, an LFM Value Added Reseller (VAR) will provide further guidance on one to one basis. To find your local LFM VAR please visit http://web.lfm-software.com/en/Value-Added-Resellers.aspx. If there is no LFM VAR in your area please contact support@lfm-software.com.

The LFM NetView project deployment process can be seen in the workflow below.
2.0 Prerequisites

2.1 Graphical Requirements

LFM NetView project publishing requires a reasonably powerful graphics card with the very latest drivers. It has been developed using NVidia graphics cards, and LFM recommends using these where possible for optimum performance and reliability. LFM have also tested with a selection of alternate cards which are detailed below.


The supported OpenGL version information is saved in the LFM log file on startup which can be found in the Temp folder as shown below which reports v4.5. The minimum needed is v4.3.

12: GL Major version supported: 4 115
13: GL Minor version supported: 5 127

**Supported Cards:**

NVidia GeForce/Quadro, or AMD FirePro W Series, with at least 1GB memory and capable of supporting OpenGL version 4.3 or later.

Please note that updated graphics drivers may be needed to meet the OpenGL requirement.

2.2 Advanced Mode Installation

LFM Server no longer requires a dongle for LFM NetView project creation. To avoid unauthorised users taking the LFM NetView creation license there is now an option to install an advanced version of LFM Server which gives access to this feature. This is illustrated in the screenshot below. LFM Server should be run from the Advanced Mode shortcut in order to be able to create a new LFM NetView project.
2.3 License Requirements

In order to publish an LFM NetView project an LFM NetView Creator license is required. For further information about LFM licenses please contact your LFM Value Added Reseller or license.request@lfm-software.com.
3.0 User Account Creation

LFM NetView projects require user accounts to be set up to control secure access. These user accounts are created in LFM Server and saved to the LFM Server project.

Go to Options > User and change the Save SQL Password option to Yes.

Switch into the Project tab and change the User Control Enabled option to Yes.

At this point you will be prompted for the administrator password. Enter the desired password in both boxes and click OK.
To set up the user accounts go to the Utilities tab and click the Users button. This will bring up the User Management Panel. To set up a new group, right click on the Group entry and select New > User Group. Name the User Group and click OK. To set the permissions for this group, left click and drag the desired permission from the Permissions section onto the appropriate group. Repeat this for all the desired permissions.

Once the appropriate groups have been set up, right click on the Users entry and select New > User. To subscribe a user to a group (which allows them rights to all the permissions within that group) left click and drag the desired group from the Groups section onto the appropriate user. Repeat this for all the desired subscriptions.

For LFM NetView, the relevant permissions are:

- **NetView User** – allowed to access/view the project and save Markups /measurements to the project.

- **NetView Guest User** – allowed to access/view the project and create Markups/measurements. However, these Markups/measurements will not be saved to the project for future use.

- **NetView Go Offline** – allowed to take an LFM NetView project offline for on-site work, presentations, client reviews etc.
4.0 Floorplan Volume Creation

In LFM Server the user can define the areas that are to be used for the LFM NetView project floorplan(s). This process replaces the need to provide a .dxf file to act as a floorplan.

The user should select ORTHO mode in order to define the floorplan(s) using Volumes in the 3D View. For further information about volume creation in LFM Server please see the LFM Server Home Guide.

The volume(s) should be saved in the Volumes tab. It is common to create two volumes, one to define the required display of the points in the floorplan, with a second volume being used to capture all of the scan sites that should be displayed in the floorplan. Scan sites that are not defined in this volume, will not be displayed in the floorplan.

The volumes should be saved to Project Volumes node and provided with a suitable name.

The screenshot below shows a sample project in the Ortho view at low resolution.
The screenshot left shows an example of a volume that is appropriate for the floorplan. Note how in the left view there are scan site markers that are outside of this volume.

It is often useful to turn on Edge Mode when selecting the floorplan volume. Edge Mode highlights areas where points are highly concentrated such as surfaces of pipes, walls, edges of structure etc.

Edge Mode can be turned on clicking on the Points drop down menu on the View tab and selecting the Edge Mode button as shown left.

The screenshot left shows an example of a volume that is appropriate for the extents. Note how all scan sites are included in this volume as opposed to the volume selected in the screenshot above.

It is often useful to turn the 3D points off when selecting the extents volume. To do this, click the Points button on the View tab at the top of the LFM Server interface.
5.0 LFM NetView Project Publishing

The LFM NetView publishing process requires access to the .zfc, .int and (if there is colour data in the project) colour panoramic _color.jpg files. Please ensure that all of these files for all datasets being published are stored in the same folder before beginning the publishing process.

Please note that if there is demolished data in the LFM Server datasets being published, you will need to re-produce the HyperBubble resources if you require the demolition to be reflected in the LFM NetView project before beginning the LFM NetView publishing process. For guidance on how to do this, please see the HyperBubble Creation and Use guide which can be accessed here – HyperBubble Creation and Use.

To begin the publishing process, right click on the project node and select Publish > LFM NetView Project. The LFM NetView project publish will look to publish any datasets that are currently loaded.

If only one dataset is loaded the message shown left will appear. Select whether you wish to publish for LFM NetView 4.1 or LFM NetView 4.2+.

If multiple datasets are loaded the message shown left will appear. Multi-dataset LFM NetView projects are supported in LFM NetView 4.2. For LFM NetView 4.0/4.1 only one point cloud can be loaded at the point of publishing the LFM NetView project.

This will bring up the dialogue as shown below. Fill in the details including pointing to the volumes created in the previous chapter for the points extents and scan site extents.
**Publish location:** The folder where the resulting files will be stored.

**Views to generate:** These components are what will make up the floorplans displayed in the LFM NetView project.

- **Floorplan name:** The name of the floorplans as displayed in LFM NetView.
- **Extents volume:** The volume that will determine which scan locations will be displayed in that floorplan. Any scan sites outside this volume will not be displayed in the LFM NetView floorplan.
- **Points volume:** The volume that will determine which points will be displayed in that floorplan. Any points outside this volume will not be displayed in the LFM NetView floorplan.
- **View direction:** The direction from which the “Points Volume” will be viewed in that LFM NetView floorplan.
- **Level of detail:** Specify the level of detail for each floorplan. For larger floorplans this should be set to *High*. For small projects *Low* is usually adequate.
- **Invert colours:** Floorplans in LFM NetView display as either white points on a black background or black points on a white background. By default floorplans will take on the current setting for the Edge Mode background in LFM Server (this can be configured in the Options > User tab). If you wish to invert these colours please tick this box.

**Resources to publish:** These options control which resources will be published for the LFM NetView project.

- **Colour:** Tick to generate colour LFM NetView BubbleViews (only available for colour scans).
- **Intensity:** Tick to generate intensity LFM NetView BubbleViews.
- **HD Textures:** Tick this to produce the required resources for the magnification window in LFM NetView.
- **Copy dataset:** Copy the LFM Server dataset (.lfd) into the publish location. This is most useful for cloud hosted projects. For locally hosted project a copy of the LFM Server dataset is likely to already be available.
- **Mask demolished areas:** Mask any demolished points from the LFM Server project as black in the LFM NetView BubbleViews.

**LFM NetView project options:**

- **Working units:** Default working units for the LFM NetView project.
- **Object processing:** Tick to include the specified objects file in the LFM NetView project.
- **Configure:** This will present the Object Processing Settings window as shown below.
• **Object File**: Browse to the location of the objects (.zgl) file

• **Object Service**: Navigate to the Object Service executable – this should have been manually installed into a folder structure without spaces e.g. C:\LFMSoftware\LFMNetViewObjectService.

• **Object inclusion**: This can be either HIGH, MEDIUM or LOW. This informs the object service to decide whether certain objects should be included in the visibility list. From a technical perspective if this is set to HIGH then imagine if you are looking at the object from the position of a scan site. If you can see at least 10 pixels belonging to the object, then it would be considered visible and added to the visibility list. 20 pixels for MEDIUM and 30 pixels for LOW.

• **Generate LFM Object Service configuration file template**: This will offer to create an immature object server configuration file, setup to serve object files rather than process the data. This is a useful starting point when setting up a new object service.

• **Select / Unselect buttons**: Select the BubbleViews the object file should be processed against. It is usual for all the BubbleViews to be selected.

**LFM NetView service server settings:**

• **Make password file**: Tick to generate a passwords file for the users and permissions in the current project. These will also be used to create users for the LFM NetView project and check their LFM NetView related permissions.

• **Offline session time limit**: Specify how many days an offline LFM NetView session will remain valid for. This is useful for ensuring that users accessing an offline LFM NetView session keep their data up to date.

On clicking **OK** you will be prompted for the location of the .zfc files. Browse to the folder and click **Select Folder**.
An overview of the required space is presented. Click OK and the publishing process will begin.

While the LFM NetView Publishing process completes, the implementer can start to prepare the Virtual Machine at the hosting centre for private cloud implementations.

Your LFM Value Added Reseller (VAR) will provide further guidance on how to set up the Virtual Machine. To find your local LFM VAR please visit [http://web.lfm-software.com/en/Value-Added-Resellers.aspx](http://web.lfm-software.com/en/Value-Added-Resellers.aspx). If there is no LFM VAR in your area please contact support@lfm-software.com.

When the publishing process is complete the message shown left will be displayed.
6.0 VHD Creation (Cloud deployment only)

For small LFM NetView projects (less than 100 scans) it is possible to copy the project from the local LFM NetView Publishing machine to a Virtual Hard Drive (VHD) that is created at the hosting centre. However for large projects, it is required that the VHD is created locally and shipped to the appropriate hosting centre. This document deals with the latter scenario.

In all cases a VHD should be used to hold the LFM NetView project data.

6.1 Creating the VHD (Windows 7)

If there isn’t enough space on the local PC it is possible to create a VHD on a network drive and attach it to the local PC as if it were a local disk.

This process creates virtual disks in the .VHD format where the minimum size is 3MB. To begin, right-click on My Computer and select to Manage. Alternately you can type diskmgmt.msc into the Windows Start search box and press enter.
The Computer Management screen will open. Click on Disk Management then Action > Create VHD.

Browse to the directory where you want the disk to reside, choose the size you want it to be (based on the estimation given at the beginning of the LFM NetView publishing process), and select dynamic or fixed. If you want the disk to expand in size as you add files to it, then pick Dynamically expanding. Otherwise pick Fixed size if you want a consistent specific size. LFM recommends selecting Fixed size. Click on OK to begin the VHD creation process.

The VHD will now be created; you can follow progress by observing the status bar at the bottom of the interface. Note, creating large VHDs on network drives can take a few hours to complete. As a guide a 500GB VHD will take about 1.5 hours to create.

Once complete, you will see the virtual drive listed in Disk Management as unallocated space…
To begin using the VHD you will need to right-click on the disk and select *Initialize Disk.*

In the Initialize Disk box keep “*MBR (Master Boot Record)*” selected and click *OK.*

### 6.2 Create a Volume

You must now create a volume by right clicking the unallocated space and selecting *New Simple Volume.*
The wizard shown left will appear. Click Next.

Choose the amount of space you want to use for the volume. For example, the maximum disk space is 511GB, make the simple volume size 485GB

Assign the volume a drive letter that is not currently being used.
Format the new volume as NTFS. Tick the relevant boxes if you want a quick format and file compression.

The wizard is complete, click on Finish.

If you have AutoPlay enabled Windows will display the pop up shown left for you to open up your new virtual hard disk.

The disk will be listed in the Windows Disk Management utility. It will also be listed on My Computer.

At this point you should contact your local LFM Value Added Reseller (VAR) for further assistance. To find your local LFM VAR please visit [http://web.lfm-software.com/en/Value-Added-Resellers.aspx](http://web.lfm-software.com/en/Value-Added-Resellers.aspx). If there is no LFM VAR in your area please contact support@lfm-software.com.
Disclaimer

All information contained in this document, with respect to LFM Software Ltd products and use, is given by LFM Software Ltd without warranty. LFM Software Ltd disclaim any and all warranties and conditions, expressed or implied, to the fullest extent permitted by law.

Neither the author, LFM Software Ltd nor AVEVA Solutions Limited, shall be liable to any person or entity for any actions, loss or damage arising from its use or possession of any information, claims, particulars, or errors in this publication, or incorrect use of the product, whatsoever.

Trademarks

LFM, BubbleView and InfiniteCore are trademarks of LFM Software Ltd in the UK. Unauthorised use of these trademarks and any associated logos are strictly forbidden. The copyright, trademark rights, or other intellectual property rights in any other product, its name or logo belongs to its respective owner.

AVEVA product/software names are trademarks or registered trademarks of AVEVA Solutions Limited or its subsidiaries and are registered in the UK, Europe and other countries worldwide. The copyright, trademark rights and other intellectual property rights in any other product referred into this manual are done so under licence from the respective owner. Unauthorised use of any of the trademarks contained in this manual is strictly forbidden.

Copyright

Copyright and all other intellectual property rights in this document and the associated software, and all constituent parts of it, including but not limited to: computer source code, object code, any data contained in it, the user manual and any other additional documentation supplied, belongs to AVEVA Solutions Limited and its subsidiaries.

All other rights are reserved to LFM Software Ltd. The information contained in this document is commercially sensitive, and shall not be copied, reproduced, stored in a retrieval system, or transmitted without the prior written permission of LFM Software Ltd. Where such permission is granted, it expressly requires that this Disclaimer and Copyright notice is prominently displayed at the beginning of every copy that is made.

The manual and associated documentation may not be adapted, reproduced, or copied, in any material or electronic form, without the prior written permission of LFM Software Ltd. The user may also not reverse engineer, decompile, copy, or adapt the associated Software. Neither the whole, nor part of the product described in this publication may be incorporated into any third-party Software, product, machine, or system without the prior written permission of LFM Software Ltd, save as permitted by law. Any such unauthorised action is strictly prohibited, and may give rise to civil liabilities and criminal prosecution.

The LFM Software Ltd products described in this document are to be installed and operated strictly in accordance with the terms and conditions of the respective licence agreements, and in accordance with the relevant user documentation. Unauthorised or unlicensed use of the product is strictly prohibited.

First published in 2016. This revision published in 2017

© AVEVA Solutions Limited and its subsidiaries 2017

LFM Software Ltd, 5 Avocado Court, Commerce Way, Trafford Park, Manchester M17 1HW.